Start a new topic

Melodics refuse to recognize Lightpad Block M

Really cool hardware, but I have to problems I cant seem to find the answer to here and Google:


1. Melodics refuses to work with the Block. I have remapped _several_ times and reset it even more, but most of the time only one section work (lower left). Worked the first day we tried it. Now? Not at all.


2. When choosing Melodics-template from Roli Dashboard, it only displays the logo at all times?! 


I  have a fair bit of tech expertise and of course everything works like it should on the iPad Pro, but when switching over to Windows.. yeah, well..


Hope someone can help!



Best,

Trond


Melodics told me that the Lightpad M app stopped working with a recent Roli firmware upgrade - presumably the one for the Studio Edition release.

As a workaround, in Dashboard you can set the Lightpad to use the Drum Block in a 4X4 mode. I use Single Channel since I suspect Melodics will not accept the multiple channels of MPE. Nonetheless, you will not get feedback from Melodics on the Lightpad.


I am a little disappointed too. It seems to be so hard to learn if Roli is choosing to drop support of this advertised capability and partnership or not from their site, so I have to learn from Melodics’ Support, but at least I can get my Lightpad M to work with Melodics through this alternate Dashboard app, albeit in a slightly drummed down way.


The Loop block is also supposed to have Melodics-specific functionality to pause, switch to performance mode, etc.See https://support.roli.com/support/solutions/articles/36000051366-controlling-apps-with-the-loop-block Is that working, when you say that “the loopblock works tho”?




1 person likes this

Same here, the Melodics plugin just shows you the big yellow M.
So not really what's promised in most videos. Feels like they kinda stoped support now they have the Lumi going for. No real solutions are given, or non working.

The loopblock works tho and otherwise great tools for production.
But the support for Melodics is really a letdown, you don't promise a rear view camera in a car and then just show a yellow window :')

Tried and failed on both Windows 10 desktop station and MacOS Catalina on a Macbook Pro.
With both my Lighpad M blocks.

I have tried all of the above, the only thing that seems to work is putting the light block in Melodics app mode. The lights go out and I do my best to remember spacing but this is just ridiculous. I got to a lesson with 16 samples and the bottom and top rows of a 4x4 configuration stop receiving input. The hardware is amazing but it seems like they dropped the ball on software functionality. I have a few apple devices but I use a windows pc. I have a apple ipad air 2 5th gen and a iphone 8+ I have installed noise on,  but I get a lot of static and distortion in the app.


 If anyone has gotten further I would greatly appreciate some help getting this device to work. If I can't get it to function on an acceptable level I guess I will be returning it.

Both the Lightpad and the Loop Blocks must be switched to Melodics mode in the Roli Dashboard. Then the blocks work fine with Melodics. I connected the Lightpad Block via USB, and the Loop block via DNA.

I also had problems with connecting the blocks to Melodics. Then I discovered, that both blocks - the Lightpad and the Loop blocks must be switched to Melodics mode in the Roli Dashboard. Afterwards it works with Melodics nicely. I connected the Lightpad M Block via USB and the Loop Block via DNA.

It seems that if you have the Seaboard block and the Lightpad block setup with the DNA connectors and the USB connected to the Seaboad, Melodics doesn't see the Lightpad.


If you plug the USB into the lightpad and still have it connected to the Seaboard via DNA, (which is awkward in my setup) it will work with Melodics

Try connecting directly (without going through a USB hub)

I had this issue, and to a degree still do, as well as finding sometimes the Seaboard wouldn't play nice either. In the end I found that the best thing was to ensure I only connected one block to my laptop at a time, ie no DNA connections as well, reboot everything, run Melodics, switch the instrument used, remap the hardware and maybe, just maybe the Lightblock would work. Frequently I'd find there'd be no leds lit or the wrong ones. I haven't yet found a 100% reliable connection yet when using the Lightpad block with Melodics but with fiddling I can generally force it into submission sometimes. I'm also finding it impossible to use Lightblock with Stagelight 4 but that's another story I'll post about later.

Thanks for the help. None of it works.

Hi, there's one more step to do ... in the Melodics App go/click on the settings text (Top Menu), and under the 'Connected Hardware' section press on the "Revert all mappings" tab. This will reset any user defined mappings to the default Roli/Melodics mapping (does a nice colour rotation display on the Lightpad block). Power down your Blocks Kit and exit the Melodics App. Restart the App and the Blocks - then when you go to a Melodics App lessons the key mappings are now active and correct for both the Loop Block and the Lightpad Block.


1 person likes this

Hi Trond, 


You mentioned you've reset the Block; is that by manually dragging the latest .syx file onto the visualiser in Dashboard? Please try this, if you haven't already done so: https://support.roli.com/support/solutions/articles/36000019190-resetting-blocks


After selecting the Melodics app in ROLI Dashboard the logo shows up until Melodics is launched or a lesson is started. 


If ROLI Dashboard and your Lightpad are both up to date, I'd recommend contacting Melodics to see if they can shine any light on this. 


Jay

Login to post a comment