Start a new topic

Roli Studio Player 1.0.0 does not upgrade and won't install AGAIN

Exactly the same as last time......but this time the previously posted fix where you delete the two db folders does not work. Is this going to happen every time there is an update because if it is....I won't update it. How hard can it be to create a working upgrade method that does not involve some hack as yet to be discovered? What about a standalone installer? Anything except this nonsense would be good.

I'm going to uninstall this because it is broken....still.

7 people have this problem

Does the issue manifest in the same way as it did previously (with the same error messages), or is there any difference?

Exactly the same way. It downloads the update, starts to install and then dies with the error message in Connect that it cannot start the Hardware Driver. The fix that worked last time does not work with this update. Anyway, one should not have to implement a fix every time. The software may be release code but the installation/installer process is alpha let alone beta. Connect does not know if the Hardware Driver service is running. I tried it and the message still appears even when the service is running. Can't we all just have a standalone installer for Studio Player? Can't we just upgrade Studio Player as we do Equator? Connect is not fit for purpose and if it cannot be fixed or no one knows how to fix it (which is what this feels like) then surely it should be consigned to the bucket. 

3 people like this

same problem seting up to use on stage tomarrow and ro;i drums says install and is no longer in my daw and nothing working reinstalled everthing and sAYING NO HARDWARE DRIVERs guess im screwed on oll the presets i made for the set

2 people like this

I agree and it would also be good to be able to bypass connect to run studio player standalone. It just adds another layer of complexity and more to the point things to go wrong when playing live. it seems to have an offline mode which is good, but I always worry that may not work oneday and will not be able to do anything If I don't have a connection. 

What is already annoying is that roli connect invariably disappears from the windows 10 system I am using. I don't quit or sign out, but it doesn't show up at the bottom with an icon and if I cycle or disply open sessions it is not there. I have to go to the start menu and restart it every time I want to do something even though the process seems to be running (3 of them) . SOmetimes I've had to go in task manager to kill it  when it didn't reappear from the start menu. 

I too have been having this problem in connect with the unable to start hardware driver. whentrying to run  or  uppgrade player.  I'm still messing about with it, trying to get it to work. ... SO please can we dispense with connect, or at least have an alternative to having to use it for studio to run or upgrade it?. 

1 person likes this

Hi Christopher, we've very sorry to hear you're still experiencing this issue. We weren't able to reproduce such an issue with this update internally, so would love to find out as much as we can about the issue.

Does the issue manifest in the same way as it did previously (with the same error messages), or is there any difference?

The steps you followed previously should resolve the issue, given that ROLI Connect itself has not changed or updated since the ROLI Studio Player v1.0.0 release. Please ensure you follow each step carefully, which should ensure this problem is resolved. If not, please do create a new support ticket with our team, so we can track the issue more closely. I'll share the steps again below in case you need them - thank you for your patience and co-operation:

Resetting the ROLI Connect database for Windows 10

First, ensure that ROLI Hardware Driver is not running as a service by launching Task Manager and heading to the Services tab. If ROLI Hardware Driver is running, do not proceed with below steps

1. Quit ROLI Connect
2. Open File Explorer and head to C:\rpkg
3. Delete the 'db' folder
4. Head to C:\Users\USERNAME\AppData\Local\rpkg
5. Delete the 'db' folder
6. Launch ROLI Connect and attempt to install ROLI Studio Player

Thank you for the clarification Christopher, I understand that you're in touch with our support team who will be able to provide further assistance regarding this issue.

  1. also is there a way to get all of the standalon sounds into studio and vice versa? At the moment they seem to be a different set of sounds so sometimes I need to use studio, other times the standalone equator, cypher etc... which seems to defeat the point of having the studio progam to link everything into one interface!!


Hi David,

We're working towards support for all existing factory presets for Equator, Strobe2 and Cypher2 in ROLI Studio Player, but unfortunately this is a non-trivial task that we're looking into. We're aiming to introduce support as soon as possible in a future update to ROLI Studio Player.

Thank you for your feedback regarding ROLI Connect - we'll be passing this on to the team to help to establish the best way to authorise ROLI Studio Player but also to ensure stability, especially during live performance situations as you describe.

Studio Player will not download.  The download starts and then stops after a few seconds.  No problem downloading Connect, Equator, Dashboard, Cypher and Strobe.  But Studio Player will not download. I've tried the "workaround" a couple times. Still no luck. I see from the posts that other people are having the same issue.

--  I submitted 2 customer service tickets for this issue 3 weeks ago and still have not received any help.

I understand that the service team is busy, but this is ridiculous.  I was excited to get a Roli Lightpad Block for Christmas. But this has been so frustrating, maybe it's time to return it.

Login to post a comment