Start a new topic

Roli Studio Player Engine Disabled

Hi guys!

I've recently updated to Studio Player 1.0.0 on Windows 10, and prior to this I had disabled the Engine. When I updated to 1.0.0, my Engine was still disabled, but now I have no method of enabling the Engine again.

I am still able to enable/disable other features of Studio Player, such as the Smart Chords and Arpeggiator featues, but am unable/haven't found a method to enable the Engine, and as such am unable to hear audio.

The Engine remainds disabled when closing and reopening Studio Player.

Is there an enable/disable feature for the Engine in 1.0.0? 

Is it recommended that I uninstall/reinstall Studio Player to regain the Engine functionality, or have I simply missed where I am supposed to enable/disable it?

Engine enabling aside, when clicking the features to assign my hardware, I am prompted to run "Roli Hardware Driver". However, I am unfamiliar with this program. This is despite having Blocks connected.

Any assistance on this matter would be most appreciated!



2 people have this problem

Hey Nathan,

The ability to disable/enable the audio engine has moved to Advanced Settings, which you can find in the settings menu at the top-right of the ROLI Studio Player window. We recommend taking a look at the full list of changes in the v1.0.0 announcement post to ensure you're familiar with the latest changes and features.

Regarding the ROLI Hardware Driver issue you're experiencing, please quit ROLI Studio Player & ROLI Connect, head to C:\Users\USERNAME\Program Files\ROLI and remove the ROLI Hardware Driver folder. Once you've done this, please download and install ROLI Connect v1.0.6 again. Once ROLI Connect has installed, select the Devices tab, which will ensure ROLI Hardware Driver has been installed and runs. Then try launching ROLI Studio Player and you should find that your devices are successfully detected. If this is not the case, please reach out to our support team who will be able to assist.

Hi Lawrence, 

Thanks for the response!

I've read through the announcement post, and can now see that the Engine disabling feature has been moved to Advanced Settings.

However, I am unable to find the Advanced Settings menu in Roli Studio Player to enable the Engine again.

Are you able to tell me where in the Settings Menu I'd find Advanced Settings?



I have the same problem while trying to assign hardware control, it shows "Please run roli hardware driver". Tried the delete and reinstall Roli Connect v.1.0.6, problem still not solve.

Hey Nathan,

It sounds as though you might need to clear the ROLI Studio Player settings file. Before you do this, we'd recommend taking a screenshot of ROLI Studio Player as it currently appears in case you wish to recall any of your previous settings.

Once you've done this, you can clear the settings file by quitting ROLI Studio Player, heading to C:\Users\USERNAME\AppData\Roaming\ROLI Studio Player and deleting the ROLI Studio Player.settings file, which will reset the state of ROLI Studio Player and re-enable the audio engine.

If this is not the case, please let us know!

Hi Mr. Bear, if you're continuing to experience issues with ROLI Hardware Driver, we recommend reaching out to our support team who will be able to assist.

This error appears when you install update 1903 for windows 10. On 1803 worked

Thanks Sergey, please reach out to our support team if you're continuing to experience this issue.

I uninstalled EVERYTHING I could find which involved searching my Mac OS library files and deleting them. Now the sound engine works, but I have the hardware driver issue. I suspect the problem was related to authorization of apps installed prior to the release of Studio Player.

Interesting note: Studio Player worked as expected running as a Logic Plugin - but not in stand alone mode.

ROLI need to create an uninstaller, or at the very least publish instructions on manual uninstallation. 

1 person likes this
Login to post a comment