Start a new topic
Answered

Logic Pro integration not working

I don't own a Songmaker Kit but I do have the component parts: Light Pad, Loop Block and Seaboard Block


All uptodate firmware wise.


I can't seem to get the logic integration working. Works with Garage Band but not Logic.


Now I do have a behringer x touch and also I use Logic Remote on an iPad as a control surface to.


However, once I've installed the Logic Control on the Loop Block the buttons don't work as advertised - eg pressing play pause as no effect. I can see in Control Bar that Logic is receiving information but it isn't responding to it


Best Answer

Hi got it working. Turns out I manually had to add Blocks as a control surface. 


Hi Robin,


Thanks for getting in touch. If you have the integration working within GarageBand it should be working with Logic on the same machine, as they use the same scripts. 


If it's not working for you in Logic, you might try re-loading the apps onto the Lightpad and Loop Blocks in ROLI Dashboard. 


Alternatively, it's possible that Logic was opened and the Blocks connected before the apps were loaded onto the Blocks. In this case, I recommend ensuring that all audio apps (and in particular Logic) are closed, then load the apps onto the Lightpad and Loop Blocks in ROLI Dashboard, and then launch Logic. Feel free to get back in touch if you have any questions.


Red

Answer

Hi got it working. Turns out I manually had to add Blocks as a control surface. 

Login to post a comment