Start a new topic

Logic Pro integration not working

I don't own a Songmaker Kit but I do have the component parts: Light Pad, Loop Block and Seaboard Block

All uptodate firmware wise.

I can't seem to get the logic integration working. Works with Garage Band but not Logic.

Now I do have a behringer x touch and also I use Logic Remote on an iPad as a control surface to.

However, once I've installed the Logic Control on the Loop Block the buttons don't work as advertised - eg pressing play pause as no effect. I can see in Control Bar that Logic is receiving information but it isn't responding to it

Best Answer

Hi got it working. Turns out I manually had to add Blocks as a control surface. 

Hi Robin,

Thanks for getting in touch. If you have the integration working within GarageBand it should be working with Logic on the same machine, as they use the same scripts. 

If it's not working for you in Logic, you might try re-loading the apps onto the Lightpad and Loop Blocks in ROLI Dashboard. 

Alternatively, it's possible that Logic was opened and the Blocks connected before the apps were loaded onto the Blocks. In this case, I recommend ensuring that all audio apps (and in particular Logic) are closed, then load the apps onto the Lightpad and Loop Blocks in ROLI Dashboard, and then launch Logic. Feel free to get back in touch if you have any questions.



Hi got it working. Turns out I manually had to add Blocks as a control surface. 


I am having the same issue and cannot manually add the blocks as a control surface.  Can you explain how you got it to work?  Thanks.


I think it was

Logic Pro X - Control Surfaces - Setup - New - Install - then I selected Roli Blocks from the list. The device was attached and running the control surface app. Have to admit I never really used it after setting it up as I purchased a Behringer X Touch soon afterwards.

Thanks for replying.  I'm trying to recreate what you did, but for some reason I don't have the Roli Blocks listed on the control surfaces list.  Any ideas?

1 person likes this

I don't recall doing anything in particular. I probably used the scan option. I would have had the devices connected to my via USB rather than blue tooth, not sure if that would make a difference

I have the same issue as Robin did but without success. My loop block arrived today but it's not working as advertised. All firmware is updated and apps are assigned to Logic Pro. I'm connected via USB and added Roli blocks as a control surface but no luck. I'm able to control the Lightpad modes with the loop block but that's it. When I push any of the other buttons I see a small dot In the control bar of Logic but nothing happens. It's like they really want to connect but are missing a vital piece of information. Very frustrating. 

Hi Mary,

The support team will be happy to help troubleshoot this. Please submit a ticket here and one of the team will be in touch! 


Good news - I got it to work. Here's how:

1. Make sure Logic Pro integration is selected within Roli Dashboard for both Lightpad and Loop blocks.

2. Close Roli Dashboard.

3. Within Logic Pro choose Control Surfaces > Setup > New > Automatic Installation


I have had a Light Pad an Loop Block for a few years and can not get them to control Logic Pro X. I have watched every video and there is not an exact step by step video on how to do this. All the Roli videos do not explain this in detail like they need to. Yes I added the new Blocks Controller assignment but how do you set up that controller? I can not get the light pad or loop block to trigger anything in Logic. Logic Pro has several setting you need to know that I do not see in any video. Input source, output source? What are those supposed to be? Not sure what I am doing wrong. Works fine on my iPad with equator but not in Logic Pro X

I am facing the same issue, I do not see Roli Blocks in the list of control surfaces in the list. I am able to use lighpad  and seaboard as MIDI but unable to use the lightblock and Loop Block. Please Help.

I also cant find logic pro on the list of devices. Auto is also not helping

Login to post a comment