Start a new topic
Answered

Equator Piano?

How can I get a piano sound on equator? When I click on the instrument Piano, the only available sound is Smoky Rhodes which of course is not a piano. Any ideas?


Best Answer

Hi Craig, 


There's a select amount of presets included in Equator Player. Upgrading to the full version expands on these presets and includes one called 'Acoustic Piano'. 


The full version of Equator gives you the ability to adjust pre-existing presets and create your own from scratch. This article explains the differences further: https://support.roli.com/support/solutions/articles/36000039076-equator-player-and-equator-compared


I hope this helps!


Jay


Answer

Hi Craig, 


There's a select amount of presets included in Equator Player. Upgrading to the full version expands on these presets and includes one called 'Acoustic Piano'. 


The full version of Equator gives you the ability to adjust pre-existing presets and create your own from scratch. This article explains the differences further: https://support.roli.com/support/solutions/articles/36000039076-equator-player-and-equator-compared


I hope this helps!


Jay

Hmm... I have the full version of Equator, Strobe and Cypher... but still no decent piano sound "Acoustic Piano" is not there.... I have 2x Seaboard blocks, a lightpad and loop block.... please any suggestions for a normal piano (not underwater, haunted, possessed by aliens etc.)

Ok for anyone still following this post.... I have realised why I could not find online piano sounds.... it is a glitch in the way the search works in equator (will raise a bug for this)


If you select "Online" for location, make sure "all" is selected for instrument, make sure "source", "articulation" and "Timbre" have nothing selected, type "Piano" into the search and click "load more".... nothing happens... keep clicking it again and again until your results appear.... it seams they are applying the paging before the filtering (which is crazy) .... I have found this works with loads of other instruments as well.


I now have my acoustic and a few others installed and working fine.


1 person likes this

Hi Chris


Thanks for bringing this to our attention.


I have flagged this bug to our software team to investigate and address in a future Equator update.

Kind regards,

Marcus


1 person likes this

Thanks Marcus... appreciated... great support BTW !!

Login to post a comment