Start a new topic
Answered

Equator/ROLI Dashboard MIDI issues

So I recently bought a Seaboard Rise. Equator is amazing, but it can be glitchy sometimes... is anyone else getting an issue where the wrong note would register half of the time? Like, it would play not just one semitone, but 6-8 semitones above the key I press. Maybe it has something to do with conflicting MIDI configurations between Equator and the ROLI Dashboard? Also, when using the Equator VST in Ableton, sometimes the synth will not play at all with MPE mode on...


Best Answer

Hi Evan,


Congratulations on your RISE! First, I'd like to make sure that ROLI Dashboard and Equator are set up correctly. Can you confirm that you've set them up according to the directions in this article? In particular, I'd like to make sure that both ROLI Dashboard and Equator are set to MPE on, a channel range from 2–16, and a pitch bend range of 48.


Regarding using Equator in Ableton, if you haven't already done so I recommend double-checking that you've set everything up according to the directions in this guide


If you've set up ROLI Dashboard, Equator, and Ableton Live according to these instructions and still have questions, please feel free to get in touch with our support team here.


Red

1 Comment

Answer

Hi Evan,


Congratulations on your RISE! First, I'd like to make sure that ROLI Dashboard and Equator are set up correctly. Can you confirm that you've set them up according to the directions in this article? In particular, I'd like to make sure that both ROLI Dashboard and Equator are set to MPE on, a channel range from 2–16, and a pitch bend range of 48.


Regarding using Equator in Ableton, if you haven't already done so I recommend double-checking that you've set everything up according to the directions in this guide


If you've set up ROLI Dashboard, Equator, and Ableton Live according to these instructions and still have questions, please feel free to get in touch with our support team here.


Red

Login to post a comment