Start a new topic

My ROLI Lightpad Block M won't connect to my NOISE app no matter what I do

When I just got my lightpad block yesterday i was so excited, then when i went to get my phone to connect it to the NOISE app the i just downloaded it would connect. Then i would leave the connection part then it would say i never connected it.


Hey Mekhi,


Thanks for getting in touch with us. What phone and version are you using? (I'd just like to make sure it meets the minimum system requirements.)


In the meantime, sometimes devices can lose Bluetooth connectivity and should be reset. I recommend following these steps:

  • Turn your phone's Bluetooth off
  • Restart your phone
  • Turn your phone's Bluetooth on
  • Connect your Lightpad Block in NOISE

If you continue experiencing this please reach out to our support team here.


Thanks,


Red


1 person likes this
I just had this happen to me today.  I could connect to Volt by Bluetooth, but not Noise or Roli Play.  I noticed that the Lightpad id name had somehow changed to several odd characters.  I could see it in the list of devices, just not get it to connect correctly. I could connect it by DNA to my Seaboard and it would work fine, but if I tried by itself it would show as connect but not work with the apps.

I was unable to rename it in the Noise app so I tried the Roli Dashboard on my Mac wired through USB.  It let me change the name to something more recognizable.  Dashboard asked if it could restart the Block to commit the changes and I let it.

When I tried to connect by Bluetooth to Noise and Play, it started working again.  I don't know how the name got scrambled, since it was fine up until recently.  Hope that helps

 

Login to post a comment