Issue


Software fails the authorisation stage despite ROLI Connect running and having a valid license. An "On no! No valid license was found" message will appear in this case.


Equator2 failed authorisationROLI Studio failed authorisation


Troubleshooting


The most common cause for this is that Connect is unable to find the license in your account due to a network issue. To check for these, please try these steps:


  • Check your Internet connection is working and stable
  • Disable any firewalls, VPNs or other network settings that could be blocking the connection
  • Connect to an alternative network
  • Double-check that you are signed into Connect using the correct account details
  • Sign out of Connect, then sign back in.

Further Help

 

If the above steps do not work, try resetting the cache by following these steps. 

  

Mac:


1. Open Finder

2. Hold shift-cmd-G, copy and paste the following pathway, replace {Username} with your Mac's username then hit Enter. 

/Users/{Username}/Library/Application Support/ROLI/ROLI Connect/


2. Delete the "API Proxy Cache" folder.

3. Ensure ROLI Connect is running and you have internet connectivity.

4. You should now be able to relaunch and authorise your software.



Windows:

1. Head to the following location on your Windows computer:

C:\Users\[your user name]\AppData\Roaming\ROLI\ROLI Connect\

2. Delete the "API Proxy Cache" folder.


3. Ensure ROLI Connect is running and you have internet connectivity.


4. You should now be able to relaunch and authorise your software.



If you are still having issues with authorising your software, please get in touch with our Support Team