The LUMI app supports both iOS and Android devices.


Based on our most recent testing, the following devices are supported by the LUMI app.

  • iPhone X or newer
  • iPad 7th gen or newer
  • iPad Mini 5th gen or newer
  • iPad Air 4th gen or newer
  • Samsung S8 or newer
  • Samsung Tab S6 or newer
  • Google Pixel 3 or newer


If you don’t see your device listed above, it may well still work. We are focusing on supporting recent, much-used models from Apple, Samsung, and Google. Other models and other brands are potentially compatible, but we can’t be definitive because we can’t test every device from the massive range of mobile devices out there. 


Similarly, we prioritise supporting the two most recent OS versions unless there is a specific circumstance where we need to either expand or further limit our support. 


The minimum OS required for the app to run properly are below:

  • iOS 14+
  • Android 10+


*The LUMI app currently runs on Android 9 but we cannot guarantee that the LUMI app will continue to function properly or perform well on Android 9 and below.