Start a new topic

RSP 0.3.0 doesn't detect devices for control. "Please run ROLI Hardware Driver"

Hardware control was working nice and dandy (except on rare occasions) with the private beta 0.2.0 version. Today I updated to 0.3.0 and can't use hardware control, because RSP claims 0 connected devices (next to the "Hardware control" widget in the header) and gives me a message asking me to "Please run ROLI Hardware Driver" in the "Assign your hardware" dialog windows.

In ROLI Connect all devices are properly listed (3 Seaboard Blocks and 3 Lightpads) and they also are coming up in Dashboard and are all working properly in the DAW (Reaper). I can use them all to play RSP and their notes are showing on RSP's UI keyboard. Only hardware control is acting up.

RSP is asking me very politely to do something about it, so I'd really like to accommodate the request. But neither do I find a button to try to start running that driver, nor do I find any trace of such a driver in Windows device manager. What can I do to make RSP happy?

This is under Windows 10 1903, the issue is happening with the standalone RSP as well as with the Vstplugin. I have updated the OS very recently, so I'm afraid I can't say whether the issue started with Windows 1903 and RSP 0.2.0, or just now with the update of RSP to 0.3.0. Sorry about that, I should have paid more attention.

Hey Frank, thanks very much for this report - we're looking into this now to see if it's anything that can be rectified in an update, but please keep us posted if you encounter any sort of change in behaviour.

Thanks for looking into it.

Indeed I got some additional info:

First, I should have mentioned that I tried a complete restart of the computer as well as re-download and install ROLI Connect to no avail.

Meanwhile I also installed ROLI Connect on my Surface tablet and on that device the hardware driver does start and work as expected (my Surface is still running Windows 10 1809). Doing that I noticed, that while on my main computer ROLI Connect does list all my devices, I haven't noticed that they are actually greyed out. I didn't notice that until I saw on the Surface how connected devices should look.

Then I searched for ROLI Hardware Driver and found an *.exe file with that name in ROLI's install directory, C:/Program Files/ROLI/ROLI Hardware Driver. When I run this *.exe, the issue is basically solved, but I have an extra window on the screen plus an extra entry on my taskbar. In windows Task Manager it will be listed as an App instead of a background service.

So it's not exactly the same as before, but it works as an intermediate workaround until you get behind the issue.

Oh, I just see that the workaround via running the exe file prevents Dashboard from connecting :(.  Well, still better that not being able to fully test the new RSP version.

Just in to report that the issue still persists after the update to RSP 0.3.0.

I'd like to try a fresh reinstall of all things related to ROLI Connect, but it seems that uninstalling ROLI Connect leaver a lot of remnants on my system. For example I don't find any way to uninstall ROLI Hardware Driver. Please instruct on how to clean my system completely from everything ROLI Connect related, thanks.

On a different note, yesterday I submitted a post regarding an issue with RSP standalone, but it still doesn't show up in the forum. It took quite a bit to formulate that report, could you please inform me whether or not it is in your inbox, and if it is, why it isn't showing? 

Hi Frank, just to confirm we've received all of your posts successfully.

We believe to have located the source of the issue affecting ROLI Hardware Driver and preventing it from launching successfully in certain situations - we'll be including a fix for this in a future update once we've confirmed and tested the fix, and we'll be looking to improve the installation/uninstallation process too.

Hi guys. Same problem using logic x 10.4.6 and RSP 0.3.1.

Is there really no procedure you can offer to clean my system from all things related to ROLI Connect and ROLI Studio Player? I am struggling to find words, so I better don't tell you how I feel about this!

IMO, the ROLI Connect/RSP devs should put everything else aside and create a clean and save way to remove the software completely, for heavens sake!

That said, a clean reinstall would probably not solve the issue I am describing anyway. My Surface now got the update to Windows 10 pro 1903. Nothing else changed since I sucessfully ran RSP with hardware control.

Lo and behold: Right after the Windows update I now am having the exact same issue with the ROLI Hardware driver on that computer too. So the root of the issue seems to be clearly an incompatibility with the newest version of Windows 10.

This issue is solved by following the instructions in the thread

Unable to start ROLI Hardware driver

Hardware control now works on both desktop and Surface :)

Thanks, Lawrence!

Great to hear, Frank! Thanks for letting us know

Login to post a comment