Start a new topic

Roli Lightpad Blocks not connecting (Windows v0.1.1)

Hello, I'm seeing some major issues with Studio Player beta version 0.1.1 for Windows. I have a seaboard block and two lightpad blocks connected to it, with all three devices recognized in dashboard. Lightpad block settings are set to rise controller, and XYZ pad (respectively).  Neither of the two lightpad blocks show in the Audio & Midi settings. Toggling autoconnect doesn't seem to do anything either.


I'm having other problems as well, but this is the most frustrating, as it's keeping me from using the block combinations as a Rise controller.


Running Win10 on a Dell G7 with 16gb RAM and 6core i7 processor


Thank you,


-Chad


Hi Chad, I think there are a couple of things you're experiencing here.


Firstly, only the 'master' block (the one connected over Bluetooth or USB) is going to appear in the MIDI settings, so in this case it's normal for only the Seaboard Block to appear.


Secondly, if the Lightpad XY and Rise Controller scripts are not working, this is due to a known issue we are currently working to fix where the faders cannot be controlled by hardware. We hope to have this fixed in the next release.


Thanks for your patience, hope this doesn't prevent you from using RSP too much.

Jared


1 person likes this
Thank you for the quick reply, Jared. Having the faders adjusted by the Rise controller block will be an absolute necessity and I’m glad to hear it’ll be rolled out next release. Additionally, are there any plans to have the audio effects mappable to lightpad blocks in RSP? I have four lightpad blocks and this seems like a good place to use them as well. Thanks again

No worries :)


Your thought on the audio effects is a very good one, and we're working on a deep integration with Lightpads in RSP right now!


Thanks,

Jared

Hi Chad, happy to let you know that RSP 0.1.2 is out, with a fix for the Macro XY/Fader controls :)


1 person likes this
Awesome! Can’t wait to try it out this evening Thanks again!
Login to post a comment