Start a new topic

ROLI Blocks latency issues in Cubase 10

Hi, I seem to be experiencing a very strange bug, which completely baffles me, to be honest. Every time I record midi notes with Blocks into Equator track (or any other if it matters) in Cubase I seem to get a full bar “negative” latency - as in notes being recorded a full bar Before the time I actually played them! I’ve been doing music production for almost 10 years now and think I can handle a 1/4 rhythm close enough, but in this case it just doesn’t work and every recorded note gets placed a lot earlier in the region. As an obvious culprit, I thought it was the auto-quantize function at first, but it is turned off by default and even so the quantize grid size is set to 1/16, not a 1/1. Moreover, I immediately plugged my generic Midi keyboard to test the issue and it worked perfectly, with the same settings. All notes were recorded accurately with zero latency issues. Coming back to roli blocks with the same pattern - and everything records almost a bar early once again... Next step was to test the bluetooth connection as I am using it wirelessly, so I’ve restarted all the software and hardware and tried again to the same result. I didn’t have a cable with me at the time, so couldn’t test if the issue persists when using blocks via cable. However, I launched Logic Pro, loaded the Equator track on it and recorded a couple of rhythms - and voila, everything recorded perfectly. Which brings me to the issue of properly communicating Midi from Blocks into Cubase. That is where I am stuck and would really appreciate your help/ideas/recommendations! As far as i can tell, the problem occurs ONLY with Blocks and Cubase Pro 10 (although, generic midi works with no latency). Every other configuration works great. Thoughts?
Login to post a comment